redoing my site

  • 10 Replies
  • 433 Views
*

DemonRaven

  • Trusty Member
  • ********
  • Replicant
  • *
  • 604
  • Disclaimer old brain @ work not liable for content
    • Chatbotfriends
redoing my site
« on: October 21, 2018, 08:12:23 am »
I finally gave up and decided to redo my site and making it a tiny more streamline and modern. I am still stuck in the I want to code it by hand though and it seems like all the web hosts want to toss ready made templates at you. I am fussy I like it done a certain way. I am having to move it back to a paid site sigh because my free one is complaining about the bots and downloads now. A new guy bought the place so he is doing it different. He is also being a jerk and trying to keep me from getting my images. He managed to freeze them.  However i am a bit more talented then he is Luckily lol. IT will be a while before it is done and it is a work in progress but two of the pages are pretty much done to my satisfaction. I wish i could figure out how to make the menu look the same as the rest and there is a annoying active  x control that I accidently added opps it makes the page poof white.for a sec. sooner or later i will figure out what i did wrong. I learn best by frustrating myself and just digging in and creating. https://chatbotfriends.site/ and https://chatbotfriends.site/home.html are done if you are curious
So sue me

*

Freddy

  • Administrator
  • **********************
  • Colossus
  • *
  • 6484
  • Mostly Harmless
Re: redoing my site
« Reply #1 on: October 21, 2018, 04:00:16 pm »
Nice layout and looking smart, well done.

I see you also made it responsive for mobile, that's working well and Google will like it.

 O0

*

DemonRaven

  • Trusty Member
  • ********
  • Replicant
  • *
  • 604
  • Disclaimer old brain @ work not liable for content
    • Chatbotfriends
Re: redoing my site
« Reply #2 on: October 21, 2018, 04:36:56 pm »
Thanks freddy I appreciate the compliments.
So sue me

*

Korrelan

  • Trusty Member
  • **********
  • Millennium Man
  • *
  • 1114
  • Look into my eyes! WOAH!
    • YouTube
Re: redoing my site
« Reply #3 on: October 21, 2018, 06:19:15 pm »
I agree with Freddy, kudos for the new design, modern and clean.

 :)
It thunk... therefore it is!... my project page.

*

DemonRaven

  • Trusty Member
  • ********
  • Replicant
  • *
  • 604
  • Disclaimer old brain @ work not liable for content
    • Chatbotfriends
Re: redoing my site
« Reply #4 on: October 21, 2018, 09:55:17 pm »
I agree with Freddy, kudos for the new design, modern and clean.

 :)

Well thank you korrelan. I appreciate that.
So sue me

*

8pla.net

  • Trusty Member
  • **********
  • Millennium Man
  • *
  • 1064
    • 8pla.net
Re: redoing my site
« Reply #5 on: October 21, 2018, 10:05:18 pm »
This link seems to have an extra double quotation mark ( " ) at the end

https://chatbotfriends.site/commerical.html"

Whatever it is, it is an easy fix.


My Very Enormous Monster Just Stopped Using Nine

*

DemonRaven

  • Trusty Member
  • ********
  • Replicant
  • *
  • 604
  • Disclaimer old brain @ work not liable for content
    • Chatbotfriends
Re: redoing my site
« Reply #6 on: October 21, 2018, 11:28:23 pm »
Thank you for finding that my old eyes missed it.   :)
So sue me

*

ruebot

  • Nomad
  • ***
  • 66
    • Demonica
Re: redoing my site
« Reply #7 on: October 22, 2018, 02:25:34 am »
You're missing an opening quotation mark at the start of "commercial" in your tag and did not declare a character encoding for this page:

Code: [Select]
<a class="w3-bar-item w3-button w3-hover-black" href=/commerical.html">Commercial</a>

view-source:https://chatbotfriends.site/home.html

I wish i could figure out how to make the menu look the same as the rest and there is a annoying active  x control that I accidently added opps it makes the page poof white.for a sec. sooner or later i will figure out what i did wrong.

It's in your <!-- Sidebar --> div class code.

And why, oh why, are you using ActiveX? That's a MicroSoft thingy and non-existent on my BSD boxen. It still does the white flash you're talking about when I refresh the page and I don't have any scripting enabled for your site.

Edit: I realize you're working on it. I'm just looking at it, I'm not trying to nitpick you. The period after "knytetrypper's chatbot Alkali" should go outside the end link tag, now it's between the end bold tag and link tag. A space between the next sentence and bring your period in left one space at the end of sentence.

Code: [Select]
One creator who passed on
        but who's work I and others have attempted to make sure doesn't is
        <a href="/AlkaliChatbot.html" title="knytetrypper's chatbot"><b>knytetrypper's chatbot Alkali</b>.
        </a>A section under downloads for <a href=
        "/Mindfiles.html" title="Mind files"><b>mind
        files</b></a> is available .

A space between "reference" and "there":

Code: [Select]
Finally under <b><a href=
        "/reference.html">reference</a></b>there are links to on-line reference material
        in various organizations

My own work is the hardest for me to proofread because I know what it's supposed to say.  :P
« Last Edit: October 22, 2018, 08:37:42 am by ruebot »

*

DemonRaven

  • Trusty Member
  • ********
  • Replicant
  • *
  • 604
  • Disclaimer old brain @ work not liable for content
    • Chatbotfriends
Re: redoing my site
« Reply #8 on: October 22, 2018, 06:45:02 pm »
I appreciate the help. Moving stuff from one site to another and then moving code, stuff gets mixed up and my brain is rusty on doing this anyway so thank you.

You're missing an opening quotation mark at the start of "commercial" in your tag and did not declare a character encoding for this page:

Code: [Select]
<a class="w3-bar-item w3-button w3-hover-black" href=/commerical.html">Commercial</a>

view-source:https://chatbotfriends.site/home.html

It's in your <!-- Sidebar --> div class code.

And why, oh why, are you using ActiveX? That's a MicroSoft thingy and non-existent on my BSD boxen. It still does the white flash you're talking about when I refresh the page and I don't have any scripting enabled for your site.

Edit: I realize you're working on it. I'm just looking at it, I'm not trying to nitpick you. The period after "knytetrypper's chatbot Alkali" should go outside the end link tag, now it's between the end bold tag and link tag. A space between the next sentence and bring your period in left one space at the end of sentence.

Code: [Select]
One creator who passed on
        but who's work I and others have attempted to make sure doesn't is
        <a href="/AlkaliChatbot.html" title="knytetrypper's chatbot"><b>knytetrypper's chatbot Alkali</b>.
        </a>A section under downloads for <a href=
        "/Mindfiles.html" title="Mind files"><b>mind
        files</b></a> is available .

A space between "reference" and "there":

Code: [Select]
Finally under <b><a href=
        "/reference.html">reference</a></b>there are links to on-line reference material
        in various organizations

My own work is the hardest for me to proofread because I know what it's supposed to say.  :P
So sue me

*

ruebot

  • Nomad
  • ***
  • 66
    • Demonica
Re: redoing my site
« Reply #9 on: October 22, 2018, 07:17:53 pm »
That's alright.

You're using two different placements of your Trademark code, too, a space between one and none in the other instance. It looks like an end paragraph tag is of place in the same block of markup. There is none at the end of the block of text, it's in the middle:

Code: [Select]
<title>ChatBotFriends &trade;</title>

 <p>If you have a company , website or blog about AI / Deep Learning <b><a href=
        "/email.htm">contact us</a></b> to be listed. I do create websites and chatbots
        (hosted at a chatbot hosting site of your choice) So <a href="/email.htm">contact
        me</a> for more information.</p>If it is game AI also known as Alife or
        artificial life your more interested in then head over to my other website
        <b><a href="http://aivirtualpetz.altervista.org/">AIVPETZ&trade; (My other
        website)</a></b>

It does look nice. Design is not my strong suit. I'm a Master of XHTML 1.0 Frameset and could base a design on that, but frames are out and that skill useless now.

I don't like those ready made templates either and learned to write XHTML and CSS at w3schools.com. I write all my code by hand and it has to be valid above all else. It's not even considered XHTML if it's not valid. My nav buttons are CSS code.


*

DemonRaven

  • Trusty Member
  • ********
  • Replicant
  • *
  • 604
  • Disclaimer old brain @ work not liable for content
    • Chatbotfriends
Re: redoing my site
« Reply #10 on: October 22, 2018, 08:56:19 pm »
Quote
I don't like those ready made templates either and learned to write XHTML and CSS at w3schools.com. I write all my code by hand and it has to be valid above all else. It's not even considered XHTML if it's not valid. My nav buttons are CSS code.

Ya I use the same place to learn and then usually go to the https://validator.w3.org/ and fight with it to fix the errors lol you are making it easy for me lol so i don't mind one bit.
So sue me

 


Bridge to the future of engineering
by Tyler (Robotics News)
November 15, 2018, 12:00:54 pm
The many interfaces of computing
by Tyler (Robotics News)
November 14, 2018, 12:00:23 pm
Emotionally Responsive Avatars
by 8pla.net (AI News )
November 12, 2018, 10:00:17 pm
World's First AI News Anchor
by squarebear (AI News )
November 12, 2018, 08:22:59 am
Looking back at Project Athena
by Tyler (Robotics News)
November 11, 2018, 12:01:49 pm
A.I. Optometrist
by LOCKSUIT (AI News )
November 11, 2018, 07:06:36 am
Highlighting new research opportunities in civil and environmental engineering
by Tyler (Robotics News)
November 08, 2018, 12:00:38 pm
Why some Wikipedia disputes go unresolved
by Tyler (Robotics News)
November 07, 2018, 12:01:07 pm

Users Online

80 Guests, 1 User
Users active in past 15 minutes:
sugumaton
[Roomba]

Most Online Today: 92. Most Online Ever: 208 (August 27, 2008, 09:36:30 am)

Articles